VKontakte.DJ
forum traveling
 

Celestial Software

...better by design

Home Support SSH Client Forums
Welcome, Guest
Please Login or Register.    Lost Password?
Slow Response with Pine Color and xterm (1 viewing) (1) Guest
Go to bottom Favoured: 0
TOPIC: Slow Response with Pine Color and xterm
#779
Slow Response with Pine Color and xterm 15 Years, 4 Months ago  
My setup:

Windows 98
Absolute Telnet 3.80 running xterm emulation
MS Dial-up Networking to establish a PPP connection to an ISP running Unix/netBSD
csh shell on the ISP host with TERM environment variable set to xterm (I forget the exact value)
Pine 4.63 on the host

The later versions of Pine allow setting colors for different things within the Pine session. When I first started using xterm on A.T. even over a dial-up connection, my response with Pine was good. However, after I started using the Pine facility to set colors, the response has slowed considerably. I have no idea whether the change is due to Pine on the host or to A.T. on the client (my computer). Any ideas? (Ask if more detail is needed.)

[ July 12, 2005, 09:14 PM: Message edited by: Brian T. Pence ]
bartlett22183 (User)
Expert Boarder
Posts: 92
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
Paul Bartlett
 
The administrator has disabled public write access.  
#780
Re: Slow Response with Pine Color and xterm 15 Years, 4 Months ago  
Paul,

I use pine 4.58 with color enabled and I've never noticed it being any slower. Not noticeably slower anyway. Adding color *can* add 10% or so more data to the datastream, even more depending on the complexity of your color scheme. This is probably not even noticeable over LAN or broadband, but might become noticeable over dialup.

In order for me to get an understanding for what you call 'considerably slower', can you give me any timings that you've noticed are different?

You might also consider renaming your .pinerc to something else and trying running pine without all of your customizations. See if you can determine if adding color is actually the culprit.

Can you send me your .pinerc so I can test with your pine settings?

Brian
bpence (Admin)
Admin
Posts: 1343
graph
User Offline Click here to see the profile of this user
Logged Logged  
 
Brian Pence
Celestial Software
SSH , SFTP, and Telnet in a tabbed interface for Windows XP, Vista, Mobile, and others
 
The administrator has disabled public write access.  
#781
Re: Slow Response with Pine Color and xterm 15 Years, 4 Months ago  
I cannot provide any timings as such, because I have not made any formally. It is only a subjective matter, but the difference is *very* noticeable, even subjectively. However, I am using dialup, so as you say that might be significant. (My most common speed is 26400bps, which is not fast even by today's dialup technology.) As for renaming my .pinerc, I don't think that would be necessary, as the difference in screen painting shows up *precisely* whether or not I have color enabled. (Also, the way I have things set up, without a .pinerc not much would work, anyway.) I am not saying that A.T. as such is involved, only that I am inquiring. I can send you my .pinerc offline.
bartlett22183 (User)
Expert Boarder
Posts: 92
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
Paul Bartlett
 
The administrator has disabled public write access.  
Go to top