Forum

SSH2 port forwardin...
 
Notifications
Clear all

SSH2 port forwarding

0 Posts
2 Users
0 Reactions
126 Views
(@DonLewis)
Eminent Member
Joined: 20 years ago
Posts: 12
Topic starter  

I am attempting to use SSH2 port forwarding to connect to a remote server and run an X application but something is not set up right. After specifying the hostname, I set up SSH2 to forward port 57999 to remote "127.0.0.1" port 5903 and checked X Forwarding. I can connect to the remote server, which is a virtual server on a Linux box running VMWare, get a command line prompt (BASH shell) but no DISPLAY variable is generated. Is the problem on my end or the server end?

[size=1][ March 03, 2005, 06:35 PM: Message edited by: Brian T. Pence ][/size]


   
ReplyQuote
(@bpence)
Member Admin
Joined: 8 months ago
Posts: 1374
 

I'm not sure what you're forwarding with 57999 and 5903. To do X forwarding, all you need to enable is the 'x forwarding' option. If the DISPLAY variable is not set, then the X forwarding option is probably disabled on your server. Check the sshd_config (probably in /etc/ssh) You'll still need to be running some kind of X software on the client side. I use xwin32 myself http://www.xwin32.com  Let me know if you need more info Brian

This post was modified 2 months ago by bpence

   
ReplyQuote
(@DonLewis)
Eminent Member
Joined: 20 years ago
Posts: 12
Topic starter  

Our sysadmin for the remote box checked the /etc/ssh/sshd_config and found:
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes

He changed it to:
AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes

He then restarted sshd, but I still don't get a display variable when I log in. Any suggestions?


   
ReplyQuote
(@bpence)
Member Admin
Joined: 8 months ago
Posts: 1374
 

And you're sure that the 'x forwarding' option is enabled in Absolute? Be sure it is enabled *before* you begin the connection.

It would be very strange to *NOT* get a DISPLAY variable if both the server and the client are both enabled. Can you double-check and make sure that he restarted the sshd?

Also check that there isn't something in your login scripts that would un-set or re-set the variable


   
ReplyQuote
(@bpence)
Member Admin
Joined: 8 months ago
Posts: 1374
 

Any word?

Brian


   
ReplyQuote
(@DonLewis)
Eminent Member
Joined: 20 years ago
Posts: 12
Topic starter  

Brian,
Yes, figured it out. The guy that installed Linux on the remote server had 2 configuration files, one in /etc and one in /user/local/etc and ssh was using the one in /usr/local/etc. Fixed the files and it now works. Very slow, but that's a different problem. At least now I have a connection. Thank you for your help.

Don


   
ReplyQuote
(@bpence)
Member Admin
Joined: 8 months ago
Posts: 1374
 

Don, There are some updates in 3.80 that eliminate some speed issues with X11 forwarding that were present in 3.63. You might want to give it a try: 

<old link removed> Please download version 3.80 or newer.

This post was modified 2 months ago by bpence

   
ReplyQuote
Share: