Forum

HPUX bash and left ...
 
Notifications
Clear all

HPUX bash and left and right arrow keys

0 Posts
1 Users
0 Reactions
85 Views
(@JamesEshelman)
New Member
Joined: 18 years ago
Posts: 1
Topic starter  

I'm using AT 9.18 and the bash shell on HPUX 11.11. All is fine except for the left and right arrow keys. In this bash do bizzare (and variable) things unrelated to moving left and right. They have always worked exactly as expected on RH Linux, where I've done the bulk of my work with AT. The up and down arrows on HPUX work exactly as expected, only the horizontal arrow keys have a problem. It seems to be some peculiarity of HPUX bash. My question is whether anyone has encountered and solved this problem and if so how? I've tried (almost) everything configurable in AT and on HPUX without even making any change (never mind the correct one) in this behavior. Spent quite a bit of time with stty on HPUX. 🙁 Current config is
01:45:37 ~ $ stty
speed 300 baud; -parity hupcl
min = 1; intr = ^C; erase = ^H; kill = ^U;
swtch ;
brkint -inpck icrnl ixoff onlcr
-iexten echo echoe echok
-echoctl -echoke
01:45:41 ~ $

speed setting lies -- disregard it.

have 7 bit on for AT, VTkeypad off.

Relatively minor annoyance mainly since it requires retyping a long command line when making changes near the beginning instead of just arrowing over, making the change and then going back, but just thought I'd ask. BTW, the 'end' key also generally works correctly for me in RH Linux bash, but also not on HPUX. Probably related.


   
ReplyQuote
Share: